Digital DX system requirements

Digital DX System Requirements

Read about Digital DX's system requirements for customers, agents, and admins.

Browser requirements for customers on web

  • Google Chrome recommended (Last 20 versions)
  • Mozilla Firefox on Windows (Last 10 versions)
  • Microsoft Edge
  • Microsoft Internet Explorer 9 and newer
    Note: The AI chat widget requires Internet Explorer 9 or newer
  • Safari on macOS (Last two versions)

Customer requirements for remote access:

  • Windows 8.1 or above
  • OS X 10.9 or above

For co-browsing requirements, see How to start a co-browse session.

Browser requirements for customers on mobile

  • Chrome recommended on Android
  • Safari recommended on iOS

Browser requirements for the Agent Workspace

  • Google Chrome recommended (Last 20 versions)
  • Mozilla Firefox on Windows (Last 10 versions)
  • Microsoft Edge
  • Microsoft Internet Explorer 10
  • Safari on macOS (Last two versions)
Remember: To use the Remote Access feature, you must use Chrome.

Browser requirements for the Web Admin Center

  • Google Chrome recommended (Last 20 versions)
  • Mozilla Firefox on Windows (Last 10 versions)
  • Microsoft Edge
  • Safari on macOS (Last two versions)

TLS encryption support

The Digital DX platform uses TLS 1.2 encryption. Earlier TLS versions are not supported.

You can enable TLS 1.2 in the Windows Registry.

Bandwidth requirements

Running the Agent Workspace does not have any special bandwidth requirements. For video chat requirements, see How to enable video chat.